WooCommerce: Corrección de "Copias desactualizadas de plantillas de WooCommerce"

Todos hemos estado allí... ¡WooPanic! ¿Que necesito hacer? Qué demonios está pasando? ¿Se va a romper mi sitio web?

Antes que nada, relájate.  No hay mucho de qué preocuparse.

En esta publicación, veremos por qué aparece ese aviso, qué problemas podría causar y qué puede hacer para solucionarlo.

Corrección del error: "Tu tema contiene copias desactualizadas de algunos archivos de plantilla de WooCommerce"
Corrección del error: "Su tema contiene copias desactualizadas de algunos archivos de plantilla de WooCommerce"

un. Por qué y cuándo aparece el error "Plantillas desactualizadas"

Los desarrolladores de temas solían (y desafortunadamente todavía lo hacen) seguir las antiguas pautas de WooCommerce en relación con la personalización.

WooCommerce solía recomendar la creación de una carpeta /woocommerce en el tema, donde los archivos de WooCommerce podrían haberse copiado y personalizado sin anular el complemento principal. Ciencia espacial hasta aquí, pero no te preocupes.

¿Por qué este sistema se considera antiguo y por qué insisto en usar ganchos para el 99 % de la personalización de WooCommerce ?

Bueno, el problema es que la personalización del tema de WordPress se realiza a través de un tema secundario hoy en día. Esto significa que si su tema principal contiene una carpeta /woocommerce, en su tema secundario habría tenido que hacer lo mismo para anular las anulaciones . Crear una carpeta /woocommerce en su tema secundario para anular la carpeta /woocommerce de su tema principal para anular las plantillas de WooCommerce... ¡ya no es una gran idea!

Aunque, algunos temas antiguos y mal codificados (¡lo siento, desarrolladores!), todavía usan esta práctica de anulación obsoleta.

Y cuando se lanza una nueva versión de WooCommerce, a veces actualizan/cambian sus archivos de plantilla. Como consecuencia, su tema obsoleto ( ¡sugerencia aquí para la solución! ) Aún podría estar intentando anular una plantilla de WooCommerce con una versión que es diferente/más antigua que la utilizada por el nuevo complemento de WooCommerce.

Los autores de temas generalmente arreglan su tema bastante rápido, por lo que se recomienda darles unos días ANTES de actualizar su complemento WooCommerce.

B. Qué podría pasar si tu tema contiene copias desactualizadas

Si los desarrolladores sobrescribieron las plantillas de WooCommerce (busque la carpeta /woocommerce dentro de los archivos del tema), si modificó las plantillas usted mismo o está usando un tema secundario, entonces algo podría fallar.

Una vez más, su tema personalizado está utilizando una plantilla obsoleta, que intenta anular un archivo más nuevo. Puede suceder algo importante (o no), principalmente después de grandes actualizaciones de WooCommerce como 2.6.

El carrito/pago podría romperse, podrían ocurrir problemas de visualización o funcionalidad... y, por lo general, puede solucionar esto mirando el estado del sistema de WooCommerce (también, consulte mi video tutorial gratuito " Solución de problemas de WooCommerce principal (más: 10 errores de WooCommerce que debe evitar "):

Estado del sistema de WooCommerce: archivos de plantilla desactualizados
Estado del sistema de WooCommerce: archivos de plantilla desactualizados

C. Cómo arreglar "Copias desactualizadas de plantillas de WooCommerce"

Aquí hay una lista de verificación que puede usar para solucionar problemas y tomar medidas sobre esta notificación de error potencialmente peligrosa.

1. Evite anular las plantillas de WooCommerce

Sí, lo siento, pero esta es la mejor solución a largo plazo que pueda tener. Ya no se recomienda anular plantillas completas.

Y si no lo anula (o los desarrolladores de su tema no lo anulan a través de la carpeta /woocommerce), entonces nunca más tendrá que luchar contra este error.

Lo que nos lleva a…

1b. ¡Cambia el tema de WordPress lo antes posible!

Seguirá recibiendo este error para siempre, siempre que use su tema actual. Evidentemente, los desarrolladores no se mantienen al día con las últimas pautas.

Ningún tema debe contener una carpeta /woocommerce. Pregunta y verifica esto antes de invertir en cualquier plantilla de WooCommerce

Pero, ¿qué sucede si está utilizando un tema antiguo y no tiene intención de cambiar a uno más moderno y optimizado?

2. Comprueba si tu tema necesita una actualización

No siempre el panel de control de WP le notificará si su tema requiere una actualización. Regrese a donde compró el tema y vea si tienen una versión más nueva.

La actualización probablemente solucionaría su problema.

Lo que nos lleva al consejo n.º 3:

3. La próxima vez, no actualices WooCommerce A MENOS QUE estés 100% seguro de que la versión actual de tu tema es TOTALMENTE compatible con la última versión de WooCommerce.

¡Esto habla por sí solo!

Hacia adelante…

4. Póngase en contacto con los desarrolladores de temas lo antes posible

Les estás pagando para que puedan ofrecerte apoyo. Dígales qué versión de WooCommerce está usando actualmente y qué archivos (ver Estado del sistema arriba) requieren actualización.

Comuníquese con ellos de inmediato y asegúrese de que puedan enviarle una copia actualizada lo antes posible, incluso antes de que la publiquen oficialmente en el mercado de temas (ya que generalmente demora unos días).

Luego, actualiza tu tema

5. Si todo lo demás falla... baja de categoría

Tienes que hacerlo tú mismo. Pero esperemos que sea solo temporal.

La mejor manera de detener esa notificación y (con suerte) esperar un poco más antes de que los desarrolladores de temas le den una actualización, es degradar WooCommerce.

No es una tarea fácil (asegúrese de realizar una copia de seguridad completa antes de actualizar y degradar, ¡todo el tiempo!), pero puede intentarlo en un sitio de desarrollo/preparación/clonación/prueba/copia antes de hacerlo en su instalación en vivo de WooCommerce .

Ve al repositorio oficial de WordPress  https://wordpress.org/plugins/woocommerce/developers/  y descarga la versión de WooCommerce que tenías antes de actualizar. ¿Quizás 2.5.5?

¡Increíble!

Descárguelo en su computadora, descomprímalo, abra su FTP o Administrador de archivos y agregue el WooCommerce "antiguo" a la carpeta / plugins de su sitio web.

Nota: no puede tener 2 complementos de WooCommerce al mismo tiempo. Un consejo simple es cambiar el nombre del que desea eliminar (por ejemplo, "XWooCommerce") para que pueda agregar el nuevo "WooCommerce" sin sobrescribir archivos. De esta forma, siempre puedes restaurar el anterior renombrándolo como “WooCommerce”.

Una vez más, este es su último recurso y, con suerte, no es necesario. ¡Solo sigue 1> 4 y deberías estar bien!

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Subir